Connectivity Issues and Transaction failures
Incident Report for Cleo
Resolved
All Cleo Integration Cloud services are performing as normal and confirmed through monitoring. Cleo will provide an RCA through the Services Update section in CIC within the next 5 business days. If you have any questions, please contact Cleo Support. Cleo will ensure that any reprocessing of transactions will be completed, working with customers as needed.
Posted Apr 02, 2024 - 21:44 CDT
Monitoring
Cleo Integration Cloud has been restored and monitoring is currently underway.
Posted Apr 02, 2024 - 20:58 CDT
Update
Between 7:30pm Central Time and 8:30pm Central Time, Cleo Engineers were alerted to a condition that caused a total of 2.5% of jobs to fail, impacting 16% of customers.
Posted Apr 02, 2024 - 20:56 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2024 - 20:52 CDT
This incident affected: CIC Studio, CIC Agent, and CIC Cockpit.