Cleo Integration Cloud: CIC Engine, Protocol Engine - Delay in Processing
Incident Report for Cleo
Resolved
CIC Engine connectivity is confirmed to be performing as normal through monitoring. All transactions are processing successfully and without delays across all inbound communications protocols.

Cleo will provide an official RCA through the Services Update section in CIC within the next 5 business days.
Posted Mar 26, 2024 - 14:45 CDT
Identified
Cleo engineers have identified the underlying cause and are actively working on a fix. We will continue to provide periodic updates.

The impact of this incident from its beginning has been limited to less than 5% of inbound AS2 and partner mailbox endpoints. Outbound connections and API-based integration flows are not affected by the current condition and will continue to process as normal.
Posted Mar 26, 2024 - 14:32 CDT
Update
Cleo engineers are continuing to investigate and will provide periodic updates.

Note: The impact is limited to inbound AS2 and partner mailbox protocols. Outbound connections and API-based integration flows are not affected by the current condition and will continue to process as normal.
Posted Mar 26, 2024 - 13:20 CDT
Investigating
Cleo Engineers have been alerted to a condition that may be affecting inbound connectivity for a subset of customers.

Note: Outbound connections have not been affected.
Posted Mar 26, 2024 - 12:22 CDT
This incident affected: Cleo Integration Cloud (CIC) Engine (Protocol Engine).