WebEDI Registration & Testing Portal Outage

Incident Report for Cleo

Resolved

Full functionality of the WebEDI Registration and Testing Portals is restored and have been confirmed through monitoring. An RCA will be available in 5 business days.
Posted Aug 05, 2025 - 14:46 CDT

Monitoring

Issue has been identified, and a fix has been implemented. We are actively monitoring the issue.
Posted Aug 05, 2025 - 13:54 CDT

Update

We are continuing to investigate this issue.
Posted Aug 05, 2025 - 13:53 CDT

Update

We are continuing to investigate the issue and will provide an update once it becomes available.
Posted Aug 05, 2025 - 12:43 CDT

Investigating

Customers attempting to connect to the Registration and Testing Portals are encountering an error accessing the portals. Our team is actively investigating the issue and we will provide updates as soon as possible.
Posted Aug 05, 2025 - 11:39 CDT
This incident affected: Cleo Integration Cloud (US) (Cleo WebEDI).