Cleo Integration Cloud: Integration Engine - API failures

Incident Report for Cleo

Resolved

Cleo engineers have applied a fix. All Cleo Integration Cloud services appear to be performing as normal and are confirmed through monitoring. Cleo will provide an RCA through the Services Update section in CIC within the next 5 business days.
Posted Oct 14, 2025 - 15:42 CDT

Identified

Cleo Engineers were alerted and identified a condition with the CIC - Integration Engine between 14:02 and 14:36 CDT. Only 10 percent of customers who use API processing were affected.
Posted Oct 14, 2025 - 15:30 CDT
This incident affected: Cleo Integration Cloud (US) (Cleo Integration Cloud - Integration Engine).