Maintenance activities for the CIC Integration Engine are currently in progress.
We have successfully completed maintenance on the CIC Protocol Engine and the CIC Router. Both components are now operating as expected.
We will continue to monitor progress closely and provide timely updates as the remaining activities proceed.
Posted Mar 21, 2026 - 23:18 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2026 - 19:00 CDT
Scheduled
Upcoming scheduled maintenance
On March 21 | 22, Cleo will perform a major update to the Cleo Integration Cloud (CIC) platform and Protocol Engine.
WHAT TO EXPECT
During the Protocol Engine update, we anticipate up to 30 minutes during which no inbound and outbound traffic will be processed.
Note:
· Outbound transactions will queue and then automatically resume processing following the update.
· There is no anticipated processing impact on API-based processes, and these transactions will continue to send and receive as normal throughout the maintenance window.
Start time: March 21 at 19:00 CDT (March 22 | 00:00 GMT)
Estimated duration: Up to 7 hours
BEST PRACTICES
Before the update
Ensure critical processes and transactions are completed prior to the scheduled update window to avoid potential disruptions.
During the update
· Refrain from creating endpoints or deploying projects in the CIC Cockpit during the maintenance window.
· Subscribe to the Cleo Status Page to stay informed by tracking the update process and receiving notifications: https://status.cleo.com/
After the update
Cleo product updates often contain security enhancements. It is strongly recommended that customers · Stay on the latest versions of CIC Agent and CIC Studio.
· Apply updates without delay to maintain optimal performance and security.