Cleo Integration Cloud: CIC Router - Inbound and Outbound Processing Delay

Incident Report for Cleo

Resolved

All scheduled processes are performing as normal and are confirmed through monitoring. Cleo will provide an RCA through the Services Update section in CIC within the next 5 business days.
Posted Apr 09, 2025 - 17:07 CDT

Update

Cleo Engineers are actively monitoring the situation to ensure that all processing is scheduled as anticipated. We will continue to provide periodic updates in the next two hours.
Posted Apr 09, 2025 - 15:52 CDT

Update

Cleo Engineers are continuing to monitor to ensure that all processing is being scheduled as expected.
Posted Apr 09, 2025 - 13:31 CDT

Monitoring

Cleo Engineers have applied changes to the CIC Router and are closely monitoring to ensure that all processing is being scheduled as expected.
Posted Apr 09, 2025 - 12:02 CDT

Update

Cleo Engineers are continuing the investigation to determine the cause of the delay in scheduled inbound and outbound processes for a subset of customers. We will continue to provide periodic updates.
Posted Apr 09, 2025 - 10:09 CDT

Update

Cleo Engineers are continuing the investigation to determine the cause of the delay in scheduled outbound processes for a small subset of customers. Improvements have been made and delays have decreased, We will continue to provide periodic updates.
Posted Apr 09, 2025 - 08:57 CDT

Update

Cleo engineers are continuing to investigate what is causing a delay in scheduled outbound processes for a subset of customers and will provide periodic updates.
Posted Apr 09, 2025 - 07:25 CDT

Update

Cleo engineers are continuing to investigate and will provide periodic updates.
Posted Apr 09, 2025 - 06:09 CDT

Investigating

Cleo Engineers were alerted to a condition that is causing delay in scheduled outbound processes for a subset of customers. Our team is actively investigating.
Posted Apr 09, 2025 - 05:06 CDT
This incident affected: Cleo Integration Cloud (US) (Cleo Integration Cloud - Router).