Cleo has successfully completed the scheduled maintenance on the Cleo Integration Cloud (CIC) API Gateway.
By following a carefully planned maintenance procedure and taking appropriate precautions, our Engineering team was able to limit the impact to API Provider traffic to only a few seconds.
All services are operating normally.
Posted Sep 19, 2026 - 20:59 CDT
Verifying
Verification is currently underway for the maintenance items.
Posted Sep 19, 2026 - 20:44 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 19, 2026 - 19:00 CDT
Scheduled
Upcoming Scheduled Maintenance- Sept 19 | 20
Cleo will perform scheduled maintenance on the Cleo Integration Cloud (CIC) API Gateway.
WHAT TO EXPECT During the update, we anticipate up to 10 minutes during which no API Provider traffic will be processed. Outbound transactions will queue and then automatically resume processing following the update.
Start time: Sept 19 at 19:00 CDT (Sept 20 | 00:00 GMT) Estimated duration: Up to 7 hours
BEST PRACTICES Before the update Ensure critical processes are completed prior to the scheduled update window to avoid potential disruptions.
During the update Refrain from deploying projects or creating new Endpoints during the maintenance window. Subscribe to the Cleo Status Page to stay informed by tracking the update process and receiving notifications: https://status.cleo.com/
After the update Cleo product updates often contain security enhancements. It is strongly recommended that customers Stay on the latest versions of CIC Agent and CIC Studio . Apply updates without delay to maintain optimal performance and security.
Thank You,
Your Cleo Team
Posted Sep 19, 2026 - 05:52 CDT
This scheduled maintenance affected: Cleo Integration Cloud (US) (Cleo Integration Cloud - API Gateway).