Cleo Integration Cloud: CIC Integration Engine - Amazon Selling Partner API Failures

Incident Report for Cleo

Resolved

Cleo Engineers have applied a fix to the condition affecting the Amazon Selling Partner API. All Cleo Integration Cloud services appear to be performing as normal and are confirmed through monitoring. Cleo will provide an RCA through the Services Update section in CIC within the next 5 business days.
Posted Feb 13, 2026 - 16:31 CST

Update

Cleo Engineers are continuing to actively work on correcting the issue affecting Amazon Selling Partner API failures.
Posted Feb 13, 2026 - 15:55 CST

Identified

Cleo Engineers have been alerted to a condition affecting Amazon Selling Partner API. CIC is experiencing API call failures to the Amazon Selling Partner API. Engineers have identified the issue and are actively working to correct it.
Posted Feb 13, 2026 - 14:33 CST
This incident affected: Cleo Integration Cloud (US) (Cleo Integration Cloud - Integration Engine).