Cleo Integration Cloud: Integration Engine - Custom task failures

Incident Report for Cleo

Resolved

All custom Java tasks are performing as normal and are confirmed through monitoring. Cleo will provide an RCA through the Services Update section in CIC within the next 5 business days.
Posted Jun 10, 2025 - 20:54 CDT

Monitoring

Cleo Engineers have applied a change and are actively monitoring the situation to ensure the custom task executes as expected.
Posted Jun 10, 2025 - 20:16 CDT

Identified

Cleo Engineers have been alerted and identified a condition with the CIC - Integration Engine affecting custom Java task that spawns multiple engines for parallel processing. As of now, Cleo does not believe this feature is widely used by many customers and we are only aware of a small subset of customers impacted.
Posted Jun 10, 2025 - 19:36 CDT
This incident affected: Cleo Integration Cloud (US) (Cleo Integration Cloud - Integration Engine).